Landing Flaps malfunction.

A place for technical help setting up your Stratocruiser with FSX
new reply
Guus
Airman
Posts: 20
Joined: 10 Mar 2019

Landing Flaps malfunction.

Post Guus »

Hi All,

More than once the landing flaps of the B377 do not work ! For example, if I taxi or when I start the approach. The flap test of 10 * downwards, then upwards seems to work if I have let the B377 roll a bit. The flap switch does move but no (flap motor) sound and no flap indication.
Sometimes when I restart, the problem is resolved, but the problem often remains. Are the landing flaps electrically or hydraulically controlled ?! Should the solution be found in 1 of these systems ? And if so, what needs to be done ...

Regards, Guus.

User avatar
Tug002
Senior Master Sergeant
Posts: 1833
Joined: 25 Oct 2013
Location: Ontario, Canada. CYSH

Re: Landing Flaps malfunction.

Post Tug002 »

Just guessing but if you are going to fast while trying to lower the flaps they will not go down. Check your speeds for the max flap deployment, it should be in the manual.

Keep smiling
Tug :)

Guus
Airman
Posts: 20
Joined: 10 Mar 2019

Re: Landing Flaps malfunction.

Post Guus »

Hi,

I have found the solution (I believe). When the approach segment starts, I have to switch to MANUAL control of the "Live Engineer"! SO SWITCH OFF: "FE Station" & "Turbos" (Hold MP was already disabled). And thus follow the "Approach Checklist"! Which for a large part takes place at the Flight Engineer! Now I can operate the "Landing Flaps" as it should be. (lower <188 KIAS ;-)

Greetings, Guus.

User avatar
Tug002
Senior Master Sergeant
Posts: 1833
Joined: 25 Oct 2013
Location: Ontario, Canada. CYSH

Re: Landing Flaps malfunction.

Post Tug002 »

Glad that you have found the problem. Happy flying.

Keep smiling
Tug :)

new reply

Return to “Boeing 377 Tech Support”

Who is online

Users browsing this forum: No registered users and 2 guests