The A2A Simulations Community

"Come share your passion for flight"
It is currently Mon Oct 16, 2017 9:02 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Wed Feb 17, 2016 4:01 pm 
Offline
Airman Basic

Joined: Wed Feb 17, 2016 3:49 pm
Posts: 2
Evening!

Firstly as a new member, let me say hello one and all!

I've taken the Windows 10 plunge today, an upgrade from Windows 7. Yesterday Bob2 worked perfectly, today under Win 10 I get the "battle of Britain English text has stopped working" error. I've been through every fix suggested in this link - viewtopic.php?f=17&t=50995 - and have also been through the latest patch release notes, all to no avail.

In addition, I have removed Bob2 from my PC, erased every last trace of it from the registry, reinstalled and tested (the text error occurs), and installed the new 2.13 patch (the text error still occurs). I've checked my graphics driver is up to date (admittedly Intel onboard HD3000, but it worked fine on Win 7 and the game is broken now both with and without the multiskin patch applied).

So reinstalls, reg cleanout, drivers, release notes, and googling old threads later, i'm stuck. If anyone knows of anything else I can try, please advise!

Thanks


Top
 Profile  
 
PostPosted: Thu Feb 18, 2016 2:49 am 
Offline
BDG
User avatar

Joined: Sat Nov 13, 2004 8:21 am
Posts: 5073
Location: wet coast, Canada
To be honest, having BoB2 run with an Intel HD3000 puts
you in a pretty select group of lucky folks, already, so
perhaps the reckless plunge into W10 was just too much
for your magic mojo... :roll: :mrgreen:

We currently have one volunteer looking into what is causing
the W10 problem, but there's no telling if it will get solved.


Top
 Profile  
 
PostPosted: Thu Feb 18, 2016 5:51 am 
Offline
Airman Basic

Joined: Wed Feb 17, 2016 3:49 pm
Posts: 2
Thanks for the response - tell your one person I am fixed!

I tried installing BoB and patch 2.13 to 2 other machines - another Intel HD, and also one with a high end Ati Radeon, both Win 10. Both faulted in exactly the same way as my own.

I returned to the drawing board, did a clean install, did none of the fixes listed above in the thread, and simply set BoB's compatibility mode as Win XP SP3. Game works like a charm now!

Why Win 7 compatibility didn't work is beyond me, being as Win 7 proper on this very machine worked 2 days ago. IT Voodoo has blagged me a working BoB again. Hopefully the info in this thread can be of use!


Top
 Profile  
 
PostPosted: Fri Feb 19, 2016 5:46 am 
Offline
BDG
User avatar

Joined: Sat Nov 13, 2004 8:21 am
Posts: 5073
Location: wet coast, Canada
Are you able to exit a 3D session (alt-x) without
the program hanging? That is the main complaint
against W10, as opposed to W8, where nothing
would ever get it to run at all.


Top
 Profile  
 
PostPosted: Fri Feb 19, 2016 9:56 am 
Offline
Airman

Joined: Sat Jan 19, 2013 12:23 pm
Posts: 27
I'm the one who's looking into W10 issues (or will be, once I get source access set up again, anyway).

Phil, I've tried just about everything besides a clean install myself, and haven't had any luck, even with WinXPSP3 mode. Give it a try in the Black Thursday Afternoon scenario to be sure—I've noticed that crashes in 3D, as opposed to crashes when leaving 3D, tend to be caused by complicated scenes with a lot going on, and show up much less frequently when things are simple.

If you do have it working solidly, excellent. That's one more potential workaround for people to try. Even so, could you grab the crashlog.txt from your BoB2 directory and post it here? More information can't do anything but help.


Top
 Profile  
 
PostPosted: Sun Apr 03, 2016 1:24 pm 
Offline
Airman Basic

Joined: Sun Apr 03, 2016 1:06 pm
Posts: 1
Hi,
I just bought the game but have been stalking it for a while saving my hard earned cash :)

Unfortunately my gaming rig has W10 on it. If I should have created a separate thread I apologise but I thought I would reply to this post and give some extra info.

I have Win10 Pro with 16GB RAM on an I7 4790K with a GeForce GTX 980Ti.
I have spent the weekend uninstaling, cleaning, re-installing, directxing, tweaking et.al. but to no avail
I do not crash on alt-x and I do not immediately crash in the game. I have done some of the training and then jumped into a RAF campaign.
In the campaign I consistently crash (english text stopped working) when I get in sight of the enemy.
I left the game running and let the aircraft fly all the way from base to enemy and also used the m:2:2 option to ffwd to a waypoint
In either case I crash at that point when I get to the enemy.

I have set all settings to minimum, maximum and many combinations in-between.

In the crash report I see one of two issues, as follows.

Bob.exe caused a EXCEPTION_ACCESS_VIOLATION in module d3d9.dll at 0023:64F44E9F, Direct3DCreate9Ex()+119455 byte(s)
Exception handler called in drawloop.
Read from location 00000005 caused an access violation.

OR

Bob.exe caused a {Not Implemented}
The requested operation is not implemented.
in module KERNELBASE.dll at 0023:7526DAD8, RaiseException()+72 byte(s)
Exception handler called in drawloop.

If this is something you can investigate please let me know what I can provide to help (if I can)

Luckily I have an older Win7 machine and that hasn't crashed yet. It's not hooked up to my bigger monitor but better than nothing!

Love the game, it's awesome. Now if I could just get it onto my big screen with win10...


Top
 Profile  
 
PostPosted: Tue Apr 05, 2016 1:30 am 
Offline
BDG
User avatar

Joined: Sat Nov 13, 2004 8:21 am
Posts: 5073
Location: wet coast, Canada
These are odd: the d3d9.dll crash is what we were
getting in win8, which we never solved - d3d9.dll is
part of windows, so we didn't have access to what
it was complaining about, and we are just too
insignificant for µ$ to bother to look at why our little
program was incompatible with their OS.

The <not implemented> is even stranger, never seen
anything close to that before, but it suggests one
must run in a compatibility mode for it to work (which
is odd because we've had quite a few reports of
folks running fine in w10 except for the alt-x exit
problem). I wonder if things have changed with w10
as a result of their OS updates. Anyway, it's all far
out of my depth.


Top
 Profile  
 
PostPosted: Thu Jul 14, 2016 7:36 pm 
Offline
Airman

Joined: Fri Nov 13, 2015 3:42 pm
Posts: 38
The two things I can suggest are
- turn off multiskin
- turn down the graphics as low as possible and work up.

My working theory so far is that Windows 8.1/10 have an issue where with directx9 games they only allow the use of 4096MB of Ram for Video usage.
(not to be confused with the 4GB enable stuff for 64 bit systems) This is to do with DirectX9 and Windows 8.1 and 10.

What this means is that when the Video ram spikes (enemy sighted) windows 7 users get a quick lag as the system ram filles up then empties. Windows 8/10 users get a crash as directx9 in those operating systems runs out of memory.

I'm working to find out what is eating up all the video memory and figuring out how to bypass it. but it's a work in progress.
Basically you need to find a sim setup that never gets over 4GB video card usage and you'll be fine. Again, Windows 7 users don't have this problem

Note that this issue is part of Directx9 in the Windows8.1 and 10 operating system, so applies to any directx9 game.
Anytime you run a directx9 game using those versions of windows, you're basically limiting your video cache to 4GB. (direct x10 and up, there is no limitation).

If you want the best of both worlds, the only option is a partitioned bootup where you can choose windows 10 or 7. Unfortunatley since directx9 has passed into legacy, i'd be shocked if Microsoft ever fixes this issue.

But complain to them and tell them you hate windows 10 because of it and maybe they'll get the idea through reduced sales/windows uptake.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group