The A2A Simulations Community

"Come share your passion for flight"
It is currently Wed Nov 22, 2017 1:37 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Install Issues...
PostPosted: Sun Jan 31, 2016 6:03 pm 
Offline
Airman

Joined: Mon May 28, 2012 6:52 pm
Posts: 19
Hi, thank you in advance.

Have downloaded (not installed yet) what I think is the right dx9. (directx_june2010). All files modified 6/2/10. Has 2 d3dx9_31_x64 and x86. Many more also. None of these are.dll. Referred to as "cabinet" files. File "DXSETUP"-SDK, "DSETUP.dll' and "dsetup32.dll". Start with the first and others will be included?

Also...unable to uninstall bob2. Wanted to start fresh. Get "cannot open INSTALL.LOG file". Relate to dx9 issue?

Just didn't want to do something without checking. As you can tell, I am technically challenged.

Will appreciate any feedback.

_________________
Mac Mini, Win7 home partition, i5 2.6ghz, 8gb, 1T, Intel Iris graphics


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Tue Feb 02, 2016 1:50 pm 
Offline
Airman

Joined: Mon May 28, 2012 6:52 pm
Posts: 19
Was concerned questions might be too sophomoric.

Thank you

_________________
Mac Mini, Win7 home partition, i5 2.6ghz, 8gb, 1T, Intel Iris graphics


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Wed Feb 03, 2016 12:07 am 
Offline
BDG
User avatar

Joined: Fri Nov 05, 2004 1:17 pm
Posts: 8754
Location: Oahu, Hawai'i
Not a sophomoric question.

I think that I know where to (now) find the official MicroSoft DirectX 9.0c End User Runtimes
that BoBII needs, and that I have always used to good effect.

I was hoping PV or arquillos may answer your question before I had to,
as they a lot smarter than I am about this DirectX stuff.

I have been repeatedly using a long ago.. saved DirectX 9.0c End User Runtimes from 2010?

----------------------

What I have long been using is a DirectX 9.0c End User Runtimes from MicroSoft with a file name of dxwebsetup.
File version of 6.0.2600.0 (if you put your mouse cursor over it) or look into it's Properties > Details window.

I shall test the new download link tonight, and advise further.. tomorrow.


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Wed Feb 03, 2016 1:12 am 
Offline
BDG
User avatar

Joined: Sat Nov 13, 2004 8:21 am
Posts: 5086
Location: wet coast, Canada
I can't answer either question. I haven't done a
DX install for several years, and I don't remember
paying any attention to the process, other than
looking in windows\system32\ when it was done
to make sure d3dx9_xx.dll from xx=24 to 43 were
all present.

Regarding the uninstall, I did a search for install.log
on my machine and found nothing, which doesn't really
tell me anything as it might be written to one of those
appdata folders that windows won't let me know anything
about, even as a full administrator on my own machine.
I have never encountered problems doing an uninstall,
the unwise.exe in the bob root folder seems to be
invoked by the control panel>programs&features>remove
process, and it's never complained at me.

If you can't get an uninstall it work, you can always do
a full manual deletion of the BoB2 folder along with a "CCCleaner"
flush of anything "Rowan" "Battle of Britain" or A2A simulations
from the registry, and that ought to empty everything out.


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Wed Feb 03, 2016 6:06 pm 
Offline
Airman

Joined: Mon May 28, 2012 6:52 pm
Posts: 19
Well...I'm flying. Graphics are bad. Turned everything down. Need some tweaking or a reinstall. Still can't uninstall.
Still says missing install log. netapi32.dll wasn't in the directxjune2010 I installed. Need to try uninstalling.

Thanks a lot guys.

_________________
Mac Mini, Win7 home partition, i5 2.6ghz, 8gb, 1T, Intel Iris graphics


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Wed Feb 03, 2016 10:15 pm 
Offline
BDG
User avatar

Joined: Fri Nov 05, 2004 1:17 pm
Posts: 8754
Location: Oahu, Hawai'i
Here is the Microsoft site where I found the DirectX 9.0c End User Runtimes dxwebsetup Application that I have always used for about 7 years when buying a new computer and installing the DX9.0c stuff that BoBII needs.

https://www.microsoft.com/en-us/downloa ... x?id=34429

When the "Save" Download menu pops up I see something I do not want.
Probably will download the MSN homepage and Bing search engine stuff. (Black arrow)

Image

So.. I drag that away.. and voila! What I do want is hidden underneath it. :evil:
Well, that is awful sneaky of them M$ folks. Also very stupid!
Anyway, I choose the download I ASKED FOR! (red lined arrow) and proceed to Save it to my Downloads folder.

Image

When you open the Properties of the dxwebsetup Application it should look like this, except the dates (this is my old download from years ago):

Image

The file version I last used, many years ago, was this File Version 6.0.2600.0

Tonight I downloaded this dxwebsetup Application from MS link above, and tried BoBII and it still works OK as before.


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Wed Feb 03, 2016 11:49 pm 
Offline
BDG
User avatar

Joined: Fri Nov 05, 2004 1:17 pm
Posts: 8754
Location: Oahu, Hawai'i
jrcct,

Quote:
Still can't uninstall.
Still says missing install log. netapi32.dll wasn't in the directxjune2010 I installed.


Never seen that.
Not sure what all that DircetX.dll stuff does nowadays.

As a developer and tester of BoBII I must have un-installed and re-installed BoBII about 50 times or more, in the last 10 years.

----------------------------------------------------------------------------------------------------------------------------

1. Even when I un-install using the normal Windows Control Panel method.. there is still a C:\Battle of Britain II folder left on my hard drive. With a lot of folders left behind. :evil:

2. Then I have to manually delete that Battle of Britain II folder every time.
I manually delete everything on my computer Battle of Britain II related.

-- Now I need to clean the REGISTRY of everything Battle of Britain II related.

3. So I open up a good and trusted REGISTRY cleaner like CCleaner, which I trust, like, and have used for 10 years, cleaning the REGISTRY every month or so.
I clean my computer's REGISTRY with CCleaner.

4. Then I usually restart my computer. An old habit, from the old days. This step may not be needed?

5. Then I install my BoBII WoV CD. (some folks download the original BoBII WoV from wherever. I forgot those links. I have a disc)

6. Then I install the v2.13 patch version.

It works! :)

-----------------------------------------------------------------------------------------------------------------------------------------------------------

Here is a link to CCleaner. Their latest Free version which should still include a REGISTRY cleaner.

http://www.piriform.com/ccleaner


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Thu Feb 04, 2016 2:52 am 
Offline
BDG
User avatar

Joined: Sat Nov 13, 2004 8:21 am
Posts: 5086
Location: wet coast, Canada
jrcct wrote:
Well...I'm flying. Graphics are bad. Turned everything down.


I presume you're installing BDG v2.13. I also assume you've read
the install readme. What have you set your GFX resolution as?

Quote:
Need some tweaking or a reinstall. Still can't uninstall.
Still says missing install log. [

You are trying to invoke the Control Panel>Programs&Features>Remove ?

Quote:
netapi32.dll wasn't in the directxjune2010 I installed.

Sorry, i don't know what your referring to here, what is this and why does it matter?

_________________
Mac Mini, Win7 home partition, i5 2.6ghz, 8gb, 1T, Intel Iris graphics
[/quote]

I don't know anything about Intel Iris graphics, but our
experience in general with Intel graphics has been
abysmal - I think we've had about 2 people with
Intel graphics (usually integrated on the motherboard)
successfully get 3D to work; typically they don't have
the muscle nor the full DX instruction set to render a
flight sim 3D. The ones that have worked had graphics
settings in the sim set to minimal, and I believe were
Intel HD 4000 or a higher number.


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Sat Feb 06, 2016 7:55 pm 
Offline
Airman

Joined: Mon May 28, 2012 6:52 pm
Posts: 19
Downloaded dx9. Deleted v206. Reinstalled. After turning off desktop recommended desktop res (in game) looks great. Running at 1920x1080x32. GFX at medium.Other settings at low or minimum so far. Have installed 213. Everything running and looking really good. Have not installed any mods or anything yet. Just been flying training and single missions. Tweaks from here I guess...like how to turn on labels. Chose colors in game but not on. See labels in bdg, don't know what to change. Been looking for manual. Haven't found yet.

Certainly want to thank you both for all your help. It's running pretty darn good considering it's an intel 5100 chip.

Again, thank you.

_________________
Mac Mini, Win7 home partition, i5 2.6ghz, 8gb, 1T, Intel Iris graphics


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Sat Feb 06, 2016 10:43 pm 
Offline
BDG
User avatar

Joined: Fri Nov 05, 2004 1:17 pm
Posts: 8754
Location: Oahu, Hawai'i
jrcct,

Quote:
Been looking for manual. Haven't found yet.


The Manual is in the Docs folder.
This Manual was rewritten a few months ago for v2.13, and is up to date. :)

The aircraft labels, and all other bdg.text "ON-OFF switches" and "adjustable variables" are explained in the Manual, as best we know what they all do.

Please also read the Release Notes.
That came with the v2.13 Download, but is also in the Docs folder.
A lot of important info there about Installation, and making settings like Forest and Tree-Line AUTO-GEN.

BoBII has a lot of user adjustable "tweaks" and is very complex that way. Even for us old-timer players! :shock:

If you have any questions, there are a few old-timers around here that can help you out. Even though we may have to refer to the Manual to do so! :wink:

Quote:
Have not installed any mods or anything yet.


Well.. for v2.13, I rounded up all of the best Mods made ever,
and nominated these "Best Mods for Stock Issue" on the General Forum.
The players voted on the ones that they like too, as to be stock v2.13 issue. Most are now included in v2.13. :)

There are still a lot of Mods around, but are hard to find.
Tomorrow I will suggest some that I have kept and personally like.
After I finish reorganizing Balloon Command. 90% finished with that Modification. :)

I modify BoBII some way every week. Part time, still a working man of the Worker Class. To poor to retire.

The (un-official) Marine Corps Enlisted Man's motto: "Kill Something Every Day, No Matter How Insignificant!"

As a Mechanic in heavy manufacturing industry, I adopted that motto, but replaced the word "Fix" instead of "Kill".
Also, as an amateur Historical Scholar, I adopted that motto, but replaced the word "Learn" instead of "Kill".

Uhhhm? Do you happen to have any Hi-Resolution and very detailed maps or photos of Portsmouth Naval Base circa 1940, in yer pocket?
I managed to collect some good intel, researching the place. I know that I am not seeing the whole truth though. Never do..
Portsmouth is on the top of my list for 1940 Targets historical rebuilds.

Quote:
Certainly want to thank you both for all your help. It's running pretty darn good considering it's an intel 5100 chip.

Again, thank you.


I am happy to see that it works OK for you.

Aloha!


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Sun Feb 07, 2016 5:09 pm 
Offline
Airman

Joined: Mon May 28, 2012 6:52 pm
Posts: 19
Doing something wrong...can't open manual or read me files in docs. Try opening with firefox, word pad & note pad, winrar. All I get is code. I know it's a pdf. This is why I fly novice.

Thanks

_________________
Mac Mini, Win7 home partition, i5 2.6ghz, 8gb, 1T, Intel Iris graphics


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Tue Feb 09, 2016 4:18 am 
Offline
BDG
User avatar

Joined: Sat Nov 13, 2004 8:21 am
Posts: 5086
Location: wet coast, Canada
Do you have a pdf viewer installed on your machine?

There are many free ones available. The original is
Adobe Reader (adobe created the pdf format). With
a pdf reader installed, you should have an "Open"
option available when you right click a .pdf file, and
it should open in the viewer. If you right click on
a .pdf and click Open without a viewer installed, W7
should offer to go find one for you.


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Tue Feb 09, 2016 3:03 pm 
Offline
Staff Sergeant
User avatar

Joined: Thu Sep 01, 2005 3:54 pm
Posts: 343
Location: Dundee
Regarding uninstalling the Sim, like Jeff I have uninstalled and reinstalled a good few times without problems.
Interestingly when I went to uninstall before trying the new installer for 2.13 it wouldnt do so had to delete and then do a wipe with CC.
I'm installed on a SSD these days.

S!

_________________
https://www.facebook.com/bob2wov


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Tue Feb 09, 2016 4:55 pm 
Offline
Airman

Joined: Mon May 28, 2012 6:52 pm
Posts: 19
Thank you PV. Didn't realize that I didn't have the reader. Switching back and forth between mac os and win 7 I assumed wrong. That's what I get.
Really don't use win7 except for the game.

Enjoying the manual. Very detailed. Still having issues getting aircraft labels. Been perusing the manual and bdg text. I'm not seeing something. Think I have everything ticked in-game
and changed in bdg. Will keep reading.

Again, thank you.

_________________
Mac Mini, Win7 home partition, i5 2.6ghz, 8gb, 1T, Intel Iris graphics


Top
 Profile  
 
 Post subject: Re: Install Issues...
PostPosted: Tue Feb 09, 2016 9:52 pm 
Offline
BDG
User avatar

Joined: Fri Nov 05, 2004 1:17 pm
Posts: 8754
Location: Oahu, Hawai'i
jrcct,

In Options > Sim > Game
Make sure that Aircraft Names is On.
(It should really say Labels, not Names, sorry.)

In the bdg. text file there are these lines for the aircraft labels. How I usually set them:

Single_Character_Label_Enemy= # Input a single character Label for the Enemy of your choice
Single_Character_Label_Friendly= # Input a single character Label for the Friendly of your choice


LABELCOLOUR_FRIENDLY = ffff00
LABELCOLOUR_ENEMY = ff0000


FADING_LABELS=ON
(below are the fading labels)

LABEL_FULL_ALPHA = 3000
LABEL_HALF_ALPHA = 6000
LABEL_ZERO_ALPHA = 9000

(The values are in meters I think. With LABEL_ZERO_ALPHA = 9000, no labels will show at 9000 meters and longer)

SHORTENED_LABELS=OFF
9What does this do? I should read the Manual, too!)

Single_Chararacter_Labels=OFF


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group